Francisco's picture

街拍vip第一站 i have installed in my KVM the image TurnKey YouPHPTube. In Panel Web i dont access page login, after input IP, my address is redirect to and? this dont access web panel of youphptube. What solutions to problem solution.

Forum:?
Jeremy Davis's picture

街拍vip第一站When you first installed, did you complete the firstboot scripts? If so, what did you enter for the domain?

街拍vip第一站YouPHPTube requires a domain to be set for it to work. And our appliance is configured to automatically redirect to the domain set at firstboot. So ideally you should configure some sort of name resolution to point a domain to your server. You could do that via a local network DNS server, or a local hosts file entry (i.e. on the computer that you are browsing from). Most (if not all) TurnKey servers that require a domain to be set should also work with an IP address. I don't specifically recall whether that is the case with YouPHPTube, but is worth a try if you don't run a local DNS service and/or don't want to set a hosts entry.

街拍vip第一站FWIW, our appliance ships with a default redirect to localhost (from when we build it), but that should be updated when you run the firtsboot scripts aka inithooks. So if you haven't already run the firstboot scripts, then please make sure that you do that before doing anything else.

街拍vip第一站Regardless of where/how you are running TurnKey you should be presented with a range of questions on firstboot (first reboot after install if installing via ISO). Exactly how you access them will depend on the appliance build and where you have it running, but assuming an ISO install on KVM, via the KVM window of your server.

街拍vip第一站If you have already run through them, you could retry the YouPHPTube inithook (either via SSH or via the KVM window). As I noted above, ensure that you set a domain that maps to your server (e.g. via DNS or a local hosts file entry) or try the IP address of your appliance (if you haven't already, I suggest setting a static IP if trying bvia IP address - you can do that from our Confconsole utility within the KVM window). The rerun the inithook like this:

/usr/lib/inithooks/bin/youphptube.py

Hopefully that will work. Let me know if it doesn't...

Add new comment